DNS issue with my wireless router

Asked By 230 points N/A Posted on -
qa-featured

I have been having a problem with my D-Link wireless router lately. When I tried to diagnose the issue with Windows Network Diagnostics, it shows the following message: Windows tried a repair but a problem still exists.

Windows Network Diagnostics

Cannot communicate with Primary DNS Server (IP REMOVED).

Network diagnostics pinged the remote host but did not receive a response. Reset the network adapters "Wireless Network Connection" Resetting the adapter can sometimes resolve an intermittent problem.

Can someone please help me? 

Thanks.

SHARE
Best Answer by clarke
Best Answer
Best Answer
Answered By 0 points N/A #99845

DNS issue with my wireless router

qa-featured

Dear Premier Account,

Please note that you won’t have to enter any quotation marks in any case, just use the words inside.

Your problem should be in your router or in your laptop.

To get this problem solved, you must know the DNS IP used by your service provider because this is the only way to know if the problem is related to with wrong IP configuration, that is more likely. You can call them and ask for DNS server IP address, serving your area.

Let's do the easy fix:

  1. Go to “start”;
  2. Click on “all programs” ;
  3. Then “accessories”
  4. Right click on command prompt
  5. Select “run as administrator”
  6. When the windows appear, write “ipconfig /flushdns” and press ENTER.

If its still unsolved go to the next step. Another solution should be :

  1. Click on “start”
  2. Write “ncpa.cpl” , in the new window
  3. Check if there is a connection named “Microsoft Virtual WIFI Miniport Adapter”.
  4. Right click on it, and click “disable”.

Now test your connection, should work. If not, follow the next one.

  1. Please go to “start”
  2. and Select press “Control Panel” ,
  3. select “Network and Internet”,
  4. select “Network and Sharing Center”.
  5. A window will pop up showing an illustration of your computer connected to the internet.
  6. In the left panel, you’ll see a menu, please choose “change adapter settings”,
  7. double click on the Wireless Network Adapter, and click on properties.
  8. A new window will appear; please double click on “Internet Protocol Version 4 (TCP/IP)” and another window will pop up.
  9. In this new Window, please check whether “obtain an IP automatically” or “Use the following ip address” is checked.
  10. This will determine if you have a pre configured IP address, known as static IP, or your D-Link router is assigning you the network configuration details, such an IP, Gateway, DNS, etc. known as DHCP.
  11. If you are using a static IP, you should notice that in the 2 lower boxes there are 2 IP addresses or it could be just one, known as your preferred DNS server. It’s should look like (172.168.2.5).
  12. Copy this address and go to “Start”
  13. in the little box that is shown first, placed above start button, write “cmd” and press enter.
  14. A black screen will appear, write ping “your dns server copied before” for example “ping 172.168.2.5”,
  15. it should start a little process, and in the end it will says the amount of packets sent, lost and received.
  16. If the amounts of sent and received packet are equals, this address is correct.

Try the DNS address that where in the second box commented before and if you obtain similar results your internet should be fine, otherwise, let's go to the next solution.

  1. Go to “start”, “
  2. Control panel”,
  3. Network and Internet” and “network and sharing center”,
  4. In the left menu choose “change adapter settings”.
  5. Double click on Wireless network adapter,
  6. Choose details, and write down the IP Address, Subnet mask, gateway and dns servers addresses.
  7. Then choose properties,
  8. Double click “Internet Protocol version 4”, and choose “use the following ip address”.
  9. In the first box insert the IP address copied before, Subnet mask in the next one, and default gateway in the third box.

Now, assuming you have the DNS provided by your service provider, compare it with the DNS written before, if they don’t match, then, insert the DNS given by the service provider in the 4th box known as preferred dns server.

  1. Then again go to “start” and in the box above it, write “cmd” and click enter,
  2. Now write “ping www.google.com/” and press enter.

It’s should return you a result of a matched sent and received packets.

If it’s doesn’t work, then we have to go to the D-Link configuration page.

A) Open a web browser and type 192.168.0.1 or 192.168.1.1 and press ENTER.

Now the admin setup page should show up, in the username field write “admin” and left the password field blank; press ENTER. If this is your first time logging in the router, it should ask you to set a new password. Choose a simple one you can easily remember.

B) Once in the admin page, click “SETUP” as top of the page, click “Internet” in the left panel, and “manual internet connection setup”, scroll down the page and you will see a primary dns server box and secondary dns box. In this place you can compare them with the IP address (es) given by the provider if they don’t match, enter the one given by the provider then go to the top of the page and click on “save settings”. Your problem should be solved. If not, follow the next instruction.

Go to the previous step starting (A) above, this time you will use your new password and it won’t ask you to change it. Continue on (B) until the step where you see the primary and secondary DNS boxes. Now we will use a different approach, we will use public Opendns server addresses. Please fill in the first box with “208.67.220.200” and the secondary box with “208.67.222.222”, this should do the work. If not, follow the next step.

Go to “start”, in the box above, write “services.msc” and press ENTER or right click on “computer” and click on “manage” and in the left panel click on “services and applications” then in the right panel click on “services”, you will see a lot of running services on the right panel, scroll down, and until show you get to “dns client”, a brief description of the service will be show, if stopped, click on “START” if it’s already started, right click “dns client” and click on restart. This should fix the problem.

If the problem is still presently we might try resetting the TCP/IP configuration from 0, to do this, go to “start”, “all programs”, “accessories”, right click on “command prompt” and run as administrator, the in the opened window, write “netsh int ip reset” and press ENTER. Restart your computer and it should be fine.

Login/Register to Answer

Related Questions