Disconnected the session because of an error in the licensing protocol.

Asked By 35 points N/A Posted on -
qa-featured

Windows 7 system get this error

Remote Desktop Connection

The remote computer disconnected the session because of an error in the licensing protocol.
 
Please try to connect to the remote computer again or contact your server administrator.
 
OK   Help   
 
 
SHARE
Answered By 0 points N/A #126706

Disconnected the session because of an error in the licensing protocol.

qa-featured

To fix this problem, you will need to reboot your computer and then try connecting to the remote computer again.

In the event that you continue to receiving this error message, you will need to contact the server administrator.
 
This problem might also be as a result of corrupt registry entries. If that is the case the following steps should help you fix it:

  • On your computer click Start, and then type regedit and hit enter.
  • Locate the registry editor window, and then go to ComputerHKEY_LOCAL_MACHINESoftwareMicrosoftMSLicensing
  • Right click on the MSLicensing, and after that click Export and then issue a name to the file e.g. RemoteKeyBackup
  • Once you have done that click Save it on the Desktop.
  • Right click on the HardwareID and then keep the keys folder under MSLicensing and click Delete.
  • After that reboot your computer so that  the changes can take effect and as well create new keys.

Regards,

Carl

Answered By 566810 points N/A #304982

Disconnected the session because of an error in the licensing protocol.

qa-featured

A lot of users have also experienced this problem when connecting to a remote computer. According to Microsoft, the cause of the problem is that “the licensing protocol handles the communication of licensing information between your computer and the remote computer. If there is an error in the licensing protocol, your computer cannot be connected to the remote computer.” They suggest to try connecting to the remote computer again.

Here’s a workaround that seems to work with most users by removing a key in the Windows registry. Click “Start,” “All Programs,” “Accessories” then right-click “Command Prompt” and select “Run as administrator.” In the command prompt window, type without quotes “regedit” then hit Enter. In the Registry Editor window, go to this location: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing]. Delete the “MSLicensing” key. Close the Registry Editor window and restart your computer.

Next, click “Start,” “All Programs,” “Accessories” then right-click “Remote Desktop Connection” and select “Run as administrator.” For users with Windows Vista and Windows 7, you need to run the “Remote Desktop Connection” shortcut using the “Run as administrator” option. For Windows XP, just run the shortcut. See if this works.

Login/Register to Answer

Related Questions