Directory Listing Denied on IIS

Asked By 0 points N/A Posted on -
qa-featured

I am building a website for my school. One part of the project is to create an electronic library from where the students can download reference material, e. g. PDF documents.

However, when I access the library URL, IIS generates this error message, "Directory Listing Denied".

How do I configure IIS to allow directory listing?

SHARE
Answered By 0 points N/A #125974

Directory Listing Denied on IIS

qa-featured

Directory Listing Denied / Error Occurs when the default / Index page is missing. The IIS looks for a default page  for eg: default.html or index.html  To enable Directory Listing you need to follow the steps shown below.

1. Go to Start > All Programs > Administrative Tools > Internet Information Service (IIS) Manager

2. Find your website listed in the left hand side and right click on it and the properties.

3. Once inside the property box, find the tab named "Documents"

4. In the "Documents" tab, find the "Enable default content page" and enable by tick.

5. Hit on the Add button and then add the document you wish to appear in the website. Eg : mywebsite.html

6. Hit Ok and the name you have added will appear on the box

7. Select the name and move up, to the first place

8. Now check the website is working and the directory listing has been cleared.

Another way to solve the problem is to rename your home page  (first page) to index.html or index.aspx

Login/Register to Answer

Related Questions