Dead Pixel and screen issues on HP EliteBook 8440p

Asked By 40 points N/A Posted on -
qa-featured

It has been a month since I started using Elite Book 8440 p and now it  is showing strange screen behavior. Some of the pixels do not perform as expected. This started to happen after prolong use of laptop so I would restart it and use it again. But once dead pixels appear in a particular session, even after restarting the defective pixels now appear more frequently than the first occurrence. Also, sometimes the screen brightness changes automatically and it becomes completely white than it changes back to the original brightness automatically. Why is this happening and what is the solution for this?

SHARE
Answered By 565940 points N/A #180775

Dead Pixel and screen issues on HP EliteBook 8440p

qa-featured

That is not a problem with your display or with your laptop’s LCD. There is probably something wrong with your video card. Try reinstalling your graphics adapter. Right-click My Computer then select Properties. Select Hardware tab then click Device Manager. Expand “Display adapters”, right-click your graphics adapter, and then select Uninstall. See image.

Once uninstalled, restart your computer. When Windows asks you to install the driver during startup, install the driver. In case you still see those glitches on your screen, try updating your video card driver. If you have an NVIDIA video card, visit NVIDIA Driver Downloads. If you are using an ATI graphics adapter, visit AMD Drivers plus Download Center.

For users with ASUS graphics accelerator, visit ASUS Drivers and Downloads. If you have a Foxconn video card, visit Foxconn Support and Service.

Answered By 0 points N/A #180776

Dead Pixel and screen issues on HP EliteBook 8440p

qa-featured

Well I have had this problem and I have a friend who also had this problem, he told me to check laptop for loose connection between an internal strip connecting LCD with the motherboard, so I open it and yes he was right sometimes you slide your laptop’s lid more than enough so it cause some loose connection or sometimes it damages the strip also so do check it.

Login/Register to Answer

Related Questions