The date and time don’t work after restarting my PC

Asked By 0 points N/A Posted on -
qa-featured

Hello, I am using windows7 operating system. I noticed that after rebooting my systems, the clock doesn’t find the exact time and date automatically; it’s retained the last time when the system was shut down. After taking the new battery I rebooted, the system has displayed perfect time. After one week system is occurring the same problem again. How can I fix? Thank You

SHARE
Answered By 0 points N/A #171668

The date and time don’t work after restarting my PC

qa-featured

Please watch the following instructions to fix your problem:

1) Click on the clock in taskbar
2) Click on "Change date and time settings…"

3) Click on "Internet Time" tab
4) Then Click on "Change Settings"

5) Give a tick on "Synchronize with an Internet time server"
6) Click on "Update now"
7) Click "OK"
8) Click "OK"

Answered By 0 points N/A #171669

The date and time don’t work after restarting my PC

qa-featured

Happy to support you!

  • Try changing the CMOS battery and set the BIOS time correctly. (This is which maintains the date and time of the computer.)
  • Verify whether every setting is set properly under “Date and time” and “Region and language” in “PC Settings”.

                                      

 

                                      

 

  • If "Sync to the Internet time" is enabled in your computer, check whether it is set correctly.

Answered By 0 points N/A #171671

The date and time don’t work after restarting my PC

qa-featured

Hello David!

Let’s simulate your clock from the easiest to hardest way.

1. From the Taskbar, click the time. Select “Date and Time Settings.” Date and Time window will pop-up in your screen.

2. Select “Change Time Zone” and click on the proper time zone in your area.

3. Once you selected the proper time and date, click “OK” button and click “Apply” button.

4. You can also manually change date and time in “Change Date and Time” button.

We can try alternative way. Maybe your CMOS/BIOS set-up is wrong.

1. Reboot your system or computer.

2. Press “F2” while rebooting Windows. You’ll see blue screen and “CMOS Set-up” window.

3. In the “Main” tab it will show you Time and Date on the upper left part of the window.

4. Set the proper time basing it on “military time” (i.e. 13:00 hr = 1pm, 18:00 hr = 6pm). Change also the date by using numpad keys in your keyboard. Press “F10” to save and exit. Your system will restart and check again your system time once you’re on desktop.

Login/Register to Answer

Related Questions