Data Transfer Too Slow in Maxtor External Hard Drive

Asked By 600 points N/A Posted on -
qa-featured

I am a college teacher and researching on various subjects and also working on different projects with students. I need to carry lots of data and that’s why I bought a Maxtor 100 GB USB 2.0 external hard drive. It was fine and I have never experienced any problem in data transfer. But data transfer is getting slower day by day. I can easily transfer data from the external hard drive to my desktop storage but when I try to copy data from another storage device to into external drive only then it works slowly.

I have formatted the drive but getting the same result. Warranty period has gone that’s why I need your valuable help.

SHARE
Best Answer by glory mathew
Best Answer
Best Answer
Answered By 0 points N/A #111949

Data Transfer Too Slow in Maxtor External Hard Drive

qa-featured

 

Halo Hanson,
 
You haven’t specified the type of windows or machine you are using therefore I will provide a number of solution to follow through:
 
Solutions    
  • First click Start button and go to Computer.
  • Right click on Computer and select Mange.
  • Click Device Manager, a dialog box will appear titled "Device Manager".
  • Expand "Disk Drive entry and locate the external hard disk.
  • Right click disk and open the "Properties" option shown.
  • A windows dialog box will appear name as "External Drive USB Device Properties".
  • In the "Policies" tab, select the "Optimize for performance check box".
  • Select the two check boxes "Enable write caching on the disk" and "Enable advanced performance.
  • Click ok and exit device manager then reboot.
To speed up your hard disk you need to configure buffer of the memory to deal with special interrupts made from the disk. Depending on the memory size(recommended is 256 Mb and above), follow by using following steps:
  • Run SYSEDIT.EXE in the command prompt.
  • Expand system.ini file window.
  • Scroll down till you find a line called [386enh].
  • Click Enter to make a blank line, and then type Irq14=4096 (which is case sensitive).
  • Click on the File menu, then choose Save.
  • Close SYSEDIT and reboot your computer.
  • Improvement will be noticed after rebooting.
If using windows vista follow through the following steps:
  • Logon to Windows Vista as an Administrator user account.
  • Go to Control Panel, System and Maintenance, then Device Manager.
  • Right click computer and select properties.
  • Click Device Manager on the left Tasks pane. Give password for the User Account.
  • Expand the Disk drives and find the hard disk installed on the system.
  • Right click on the hard disk device select “Properties”.
  • Click on “Policies” tab.
  • Tick “Enable advanced performance” checkbox nested under “Enable.
  • Write caching and select for performance improvement.
  • Click ok and exit device manager.
Hope the solution will help.
 
Glory
Answered By 0 points N/A #111950

Data Transfer Too Slow in Maxtor External Hard Drive

qa-featured

In order to speed up your Maxtor, you may try running defragment.

Press start > All programs > Accessories > System tool > Disk defragment.

Then, click start defrag button to start compressing the files and folders on the hard disk. Once done, click exit. Start copying files to the Maxtor drive to check if it works faster.

Login/Register to Answer

Related Questions