No of visitors who read this post: 4166
Category: Windows 7
Type: Question
Author: EUGENE
No votes yet

I'm having a setup here. But along the while the error came up. I don't know why I have this error.

I have an OS running good and fine Windows7 all good to me.

Provide some solution.

Thanks.

SetupXML

CXMLFile() -> couldn’t instance IID_IXMLDOMDocument2

                                                OK

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 31689

Hi EUGENE,

It seems related to your registry and temporary folders. You can clean your registry and temporary files with CCleaner or your favorite cleanup programs. But if the error still pops up, it could be coming from a program.

I've been searching on the web, and this error only related to CorelDraw program. Do you have any CorelDraw installed on your computer? If you want you can follow this instruction in the Forum given below. The post which solved your error problem is at the end of a page in CorelDraw Forums

# Comment Id: 112398

It’s because you are using an old version of Corel DRAW/

And if you are using X3 you have error in the Registry......

Just follow these steps.

  • Delete any X4 folders & registry keys.
  • Restart
  • Uninstalled all MSXML Parser 6 stuff (SPs, SDK).
  •  Re-install MSXML Parser 6.
  •  Copy setup folder from install DVD to a temp folder on the  hard drive.
  • Tried running the Corel draw X4 SP1 install, it gave the expected error message that the X4 product wasn't installed.
  •  Now ran Setup.exe
  • Ran X4 SP

# Comment Id: 132902

After doing everything I could find on the internet I still had the same problem.

After talking to Corel this is what they said.

I would suggest turning off or disabling your Firewall, defender, antivirus, UAC (User Account Control) temporarily. Please make sure that the antivirus is not running on background, go to your task manager>processes then look for your antivirus software, select it then end the process. 

It would also help to empty the temporary files and cache. 

If the issue persists, create a new user account with administrator rights, and then run the installation on it. We can delete the user account later on and we will only use it for installation. 

I was unable to change my Firewall settings so I found this article which fixed some corrupted files in my Windows 7 64

http://support.microsoft.com/kb/929833

It found and replaced some corrupted system files.

After that I successfully accessed and turned off the firewall and the antivirus (like I did before) then it installed fine.