Could not mark all packages for installation or upgrade

Asked By 0 points N/A Posted on -
qa-featured

I have got the Update Package in Linux Mint, however, this seems to be broken as I received an error on starting the update. I tried removing the package but it also won't let me. I am certain that there are contents in this update that is stopping me from running the update but I am not sure what to do next. I am asking for help on resolving this matter. Thank you.

Could not mark all packages for installation or upgrade

The following packages have unresolvable dependencies.

Make sure that all required responsibilities are added and enabled in the preferences.

Pglgui:

Depends: libpolkit-qt-1-1 but it is installable

 Depends: libqtcore4 (>=4:4.7.0 ~ beta1) but 4:4.6.2-0ubuntu4.3 is to be installed

Close

 

SHARE
Answered By 70 points N/A #122769

Could not mark all packages for installation or upgrade

qa-featured

Hello,

Linux Mint is a nice Linux edition that I love very much. Unfortunately, you’re unable to install some packages. This is because of dependence on other packages.

According to your error message, the packages you’re trying to install requires a library called “libqtcore4”. This is a Qt core module that runs programs related to Qt 4.

Download libqtcore4 (4:4.8.1-0ubuntu4.5).

Also, you can install it using Terminal command. Press “Ctrl + T” and run this command:

sudo apt-get libqtcore4

Now, your packages should be installed perfectly.

Login/Register to Answer

Related Questions