Could not backup Sage ACT PRO 2012

Asked By 10 points N/A Posted on -
qa-featured

I was trying to backup ACT! PRO 2012 but always failed with the error below.

I have tried to use various names and also tried to save the backup in my desktop, removable device and to my hard drive but I still failed to continue.

The database name has an apostrophe.

I need help. Thank you.

The following error occurred during backup. The backup was canceled.

Error:


Sage ACT!       
       
The following error occurred during backup. The backup was        
canceled.       
       
Incorrect syntax near 'LapTop'.       
Unclosed quotation mark after the character string ', NOSKIP,       
STATS=10, NOFORMAT'.       
PRC_MAINT_BACKUPDB: ERROR EXECUTING DATABASE BACKUP       
STATEMENT

SHARE
Answered By 0 points N/A #105778

Could not backup Sage ACT PRO 2012

qa-featured

Hello Keith,

You were trying to backup ACT! PRO 2012 and receive the following error message: "Line 1: Incorrect syntax near 'LapTop'. Unclosed quotation mark before the character string', NOSKIP, STATS=10, NOFORMAT'. PRC_MAIN_BACKUPDB: ERROR EXECUTING DATABASE BACKUP STATEMENT."
 
The reason is if the database was saved to your Windows Desktop when created or if the file path to your database contains an apostrophe. You should move the database files to a folder off your Desktop, or away from the file path containing the apostrophe, in order to create a Back Up or Save Copy As.
 
It will requires you to detach your database from the ACT! instance of the SQL Server, copy the database files to the new location, and then reattach your database to the ACT! instance of the SQL Server. 
 
Follow these steps:
 
Note: Images in your version of ACT! may differ slightly from the ones below.
 
1. Close ACT!
2. Click Start, and then click Run. The Run dialog box appears.
3. In the Open field, enter actdiag (ACT! 2007 and later), act8diag (ACT! 2006), or act7diag (ACT! 2005), and then click OK. The ACT! Diagnostics utility launches.
 
 
 
 
4.Click the Databases from the navigation bar. A list of your databases will appear.
 
Note for Sage ACT! 2011 Users: The "Database" and "Server" options have been relocated to the top toolbar.
 
The following steps are the same regardless of what version of ACT! you have installed.
 
 
 
 
5. Click the rectangle on the left side of the DATABASE name that you wish to Detach. The entire row displaying the database information becomes selected.
6. Note the path in the DATABASE FILE LOCATION column.
7. Right-click the rectangle on the left side of the DATABASE name, and then click Detach Database from the shortcut
    menu. The following Detach Database dialog box will appear.
8. Ensure that this dialog box reflects the correct database name, and then click Yes. The following Detach Database window appears.
9. Click OK. Your database is detached from the ACT! SQL Server Instance.
10. Launch Window Explorer (or My Computer).
11. Navigate to the location noted in step 6.
12. Copy the .ADF and .ALF files along with the database files folder associated with your database. If the name of your database is Contacts then you would copy Contacts.adf, Contacts.alf, and Contacts-database files.
13. It is recommended that you create a folder on your computer named ACT Database.
14. Paste the two files and folder that you copied in step 12 into this new folder.
15. Launch ACT!. Click the File menu, and then click Open Database. An Open dialog box appears.
16. Change the Files of Type field to ACT! Database (*.ADF) (as illustrated below)
 
 
 
17. Navigate to the folder you created in step 13. Open your database by double-clicking the .ADF file. Opening your ACT! 2005 database after detaching it will force it to reattach to the ACT! instance of the SQL Server. The following ACT! dialog box appears.
 
 
 
18. Click OK to began the verification of your database. The following ACT! dialog box appears.
 
 
 
19. Click OK to open your database.
 

Login/Register to Answer

Related Questions