Connection attempt failed with “ECONNREFUSED – Connection refused by server”

Asked By 200 points N/A Posted on -
qa-featured

Hi!

I am using Filezilla and getting this error "Connection attempt failed with "ECONNREFUSED – Connection refused by server" when I tried to connect to my FTP accounts.

The old version of Filezilla is working perfectly. I really need to get this working because, I am using it for my own domain. I'm planning to create more domains in the future. 

I've tried watching videos on how to do it, but got no success. I really need a very good trick for this one. Is it possible that the Win 7 firewall is blocking the Filezilla server?

Any solutions would be most helpful. Thanks.

SHARE
Best Answer by Carl Jack
Answered By 0 points N/A #112525

Connection attempt failed with “ECONNREFUSED – Connection refused by server”

qa-featured

Well, lets just try a few things to help you solve these problems. Disable Windows 7 User’s Account Control it can be found in the Users control panel User’s Accounts as well as your firewall and filtering software now try to access the options menu and configurations settings in FileZilla where you can find an FTP that can in two modes which is the active and the passive now try to choose the opposite and connect you can also check if the FTP is in port 21, some instances it will run on different ports so might as well do the checking.

Best Answer
Best Answer
Answered By 0 points N/A #112527

Connection attempt failed with “ECONNREFUSED – Connection refused by server”

qa-featured

Hello Michelle,

That issue may be occurring because Filezilla may be blocked by the firewall that you are using on your OS or whichever security application that you are using on your computer and therefore to resolve the issue you will need to do the following:

  • First you will need to open the Control Panel (All Items View).
  • And then you will click on the Windows Firewall icon.
  • After that you will click on the Allow a program through Windows Firewall link in the left blue pane.
  • And then click on the Change Settings button.
  • After that go to left side and then check the program exception Name box to allow, or uncheck to unallow through Windows Firewall.

Regards,

Carl

Login/Register to Answer

Related Questions