Confusion about the kickstart version of Amiga 500 archon

Asked By 30 points N/A Posted on -
qa-featured

Hi everyone, have a good day, My old Amiga 500 archon has been broken, now I have planned to buy a new one but I am a little confused about the kick-start version. I have heard that kick-start 1.2 is more well-matched than kick-start 1.3 because it can run all kick-start 1.3 games. Please guide me as soon as you see this post because I am going to get it tomorrow. Thanks

SHARE
Answered By 80 points N/A #138801

Confusion about the kickstart version of Amiga 500 archon

qa-featured

Greetings Doridnamincey,

 

Well after some search I've found out that the most games were made for Kickstart 1.3. Earlier version cannot boot from HDD so all in all I would recommend you to get the Kickstart 1.3.

You can read about this at this website and see the differences. http://wiki.classicamiga.com/Kickstart_Roms_Explained.

There are some games that require 1.2 but overall more games are made for 1.3. Unless you require to play a specific game i would go with 1.3.

 

Hope this helps you,

Regards

Login/Register to Answer

Related Questions