Configuring Dual Booted PC Error on Activating XKB Configuration

Asked By 0 points N/A Posted on -
qa-featured

Hi,

I dual booted fedora 10 with Ubuntu. I guess I configured it correctly.

However I can't run it. I'm getting an system error after bootup.

Is anything not configured correctly?

Please help!

Thank you.

Error:

Error activating XKB configuration.

it can happen under various circumstances:

-a bug in libxklavier library

-a bug in X server (xkbcomp, xmodmap utilities)

-X server with incompatible libxkbfile implementation

X server version data:

The X.Org Foundation

10600000

If you report this situation as a bug, please include:

  • The result of xprop –root | grep XKB
  • The result of gconftool-2 –R /desktop/gnome/

peripherals/keyboard/kbd

SHARE
Best Answer by Allen Kenneth
Answered By 0 points N/A #122942

Configuring Dual Booted PC Error on Activating XKB Configuration

qa-featured

Hi dear,

I think on your case, you don't have any problems on your keyboard and you're just getting this error message after you login.

Well, if yes then try this.

This is the only method I know that  works and should also resolve your case:

Add a symlink../usr/X11R6/lib/X11/xkb/rules: ln -s xorg.lst xfree86.lst

 

Honestly, I can't assure you that this will be a permanent solution for your problem but if it worked, then your setxkbmap will be ok again.

And lastly try updating your XKB. I hope recent updates have already fixed this problem.

 

David

Best Answer
Best Answer
Answered By 0 points N/A #122943

Configuring Dual Booted PC Error on Activating XKB Configuration

qa-featured

Hello Michelle, 

This error can be seen once anyone update fedora in their laptop. And also at instances where customization of keyboard in gnome hardware preferences take place. Here are some methods worth trying. 

This can be simply solved by adding a symlink in /usr/X11R6/lib/X11/xkb/rules: ln -s xorg.lst xfree86.lst.
This one is temporary, but setxkbmap will work again on it's feet. 

Someone may have run into this situation after reconfiguring their keyboard layout using a code like this: sudo dpkg-reconfigure keyboard-configuration. 

They can solve the problem by executing this code: sudo dpkg-reconfigure kbd

Hopefully future updates of xorg will be free from these kind of problems.

Glad to be a help!

Answered By 0 points N/A #122944

Configuring Dual Booted PC Error on Activating XKB Configuration

qa-featured

You haven't mentioned which Linux is generating errors either Fedora or Ubuntu. However the error is because of unmatched keyboard configurations. You'll have to reconfigure your keyboard.

You can do so by using following commands:

Either this

sudo dpkg-reconfigure keyboard-configuration

Or this

sudo dpkg-reconfigure kbd

Answered By 985 points N/A #122945

Configuring Dual Booted PC Error on Activating XKB Configuration

qa-featured

Hello Phoebe Jackson,

Hope that my message finds you well.
You can Change the keyboard model from "Apple Aluminium Keyboard" to "Apple" in the Keyboard Preferences.

Also You can try making sure that 'grep XkbRules /etc/X11/xorg.conf' returns:
Option "XkbRules" "xorg"
if not, change it, then the same for /etc/X11/XF86Config.
then run setxkbmap -rules xorg -layout us

Hope this solution will help you and please let me know if you need anything else.
Kind regards,

Login/Register to Answer

Related Questions