Computer’s Registry settings are disabled

Asked By 10 points N/A Posted on -
qa-featured

Hello!

I have a problem to discuss here at techyv. First of all when i click on run and type regedit, I receive a message that
"Registry editing has been disabled by your administrator". I want a solution for this problem as i have to edit registry settings of my computer. Please brief answer is required.

Registry editing has been disabled by your administrator
SHARE
Best Answer by Lucky Luciano
Best Answer
Best Answer
Answered By 200 points N/A #118339

Computer’s Registry settings are disabled

qa-featured

Hi Qamar,

A very brief answer would be;

  • Since you have not mentioned that you are "the administrator" or even part of the administrator group of users, then I'm assuming that your user account has no privileges or is a limited account, therefore you cannot use the registry editor.
  • It may be your computer, but when you installed windows XP (from the looks of your screenshot, I'd say you are using Windows XP) you may not have set your account as the Administrator.
  • Try going to Control Panel then User Accounts. Check your username if it is an Administrator.
  • Also, Change the way users log on or off and deselect the "Use the Welcome Screen". Press Apply Options and Restart your computer.
  • When you log on, type "Administrator" as the username and press Enter. Usually the default Administrator account has no password set. Once you're logged in, then see if you can edit the registry.

However, if you know that you ARE the Administrator, then try the steps below:

  • Click Start.
  • Select Run.
  • In the box, type this command string: (You may copy and paste it too).
  • REG add HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem /v DisableRegistryTools /t REG_DWORD /d 0 /f
  • Then press Enter.
  • And you're done! You should now be able to launch the Windows Registry Editor.

Another method, which is only for Windows XP Professional, is to use the Group Policy Editor:

  • Click Start.
  • Select Run.
  • In the box, type this command: (You may copy and paste it too).
  • gpedit.msc.
  • Then press ENTER.
  • The Group Policy window should appear.
  • On the left hand pane of the window, click:
  • User Configuration.
  • Then, Administrative Templates.
  • Then, System.
  • Now, double-click Disable registry editing tools.
  • Then set it to Not Configured.
  • However, If the setting is already at Not Configured, then set it to Enabled, and click Apply. Then change it back to Not Configured. This will ensure that the DisableRegistryTools registry value is omitted entirely.
  • And finally, Exit the Group Policy Editor.

Did that do it? Good luck!

Answered By 0 points N/A #118340

Computer’s Registry settings are disabled

qa-featured

 

Your computer’s registry setting is disabling from before. To enable this I will suggest you some different ways.

First option is to download software that can edit registry setting. If you can not manage it or operate it then you have to do it manually.

Manually you can do this. Just follow this path. Go to start button then click on run then write gpedit.msc and press enter. A window will appear just like this.

Go to User Configuration then Administrative Templates then System then prevent access to registry editing tools then Properties click on and Set it to Not Configured. By then you can edit your registry setting.

User Configuration-Administrative Templates-System-prevent access to registry editing tools-Properties- Not Configured

Login/Register to Answer

Related Questions