Catalyst control center for linux

Asked By 10 points N/A Posted on -
qa-featured

Hi everyone,

Trying to configure my ATI Radeon 9800 video card but when I try to get to the ATI Catalyst Control Center on Linux I get this error message:

No ATI graphics driver is installed, or the ATI driver is not functioning properly.

Initialization Error

There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

No ATI graphics driver is installed, or the ATI driver is not functioning properly.

Please install the ATI driver appropriate for your ATI hardware, or configure using aticonfig.

I am newbie in Linux so any assistance will be much appreciated.

Thanks.

SHARE
Answered By 0 points N/A #123774

Catalyst control center for linux

qa-featured

Hi,

I give you tips basically on Ubuntu Natty. I don't know what your type of Linux or your computer system.
Open the Terminal then type:

Sudo apt-apt-repository ppa:ubuntu-x-swat/x-updates

Sudo apt-get update

Sudo apt-get install fglrx

If your system is 64 bit, Install this BEFORE anything:

Sudo apt-get install ia32-libs

Type this command:

Sudo apt-get remove fglrx

Now find your link driver here. Then type this in the terminal:

Wget http://www2.ati.com/drivers/linux/your-link-ati-driver-type.run

Change "http://support.amd.com/en-us/download" in your auto drivers' link. You can get it from here.

After you download, right click the Run file then sets it to run as an executable. Then type again in the terminal:

Cd /path_of_the_file

For installing in 32 bit system:

Sh ./ati-driver-installer-11-5-x86.x86_64.run

In 64 bit system.

Sh ./ati-driver-installer-11-5-x86.x86_64.run  –buildpkg Ubuntu/natty

Sudo dpkg -i fglrx*.deb

Once it's done, type:

Sudo aticonfig  –initial  -f

Finish.

If you still get the error warning after you run the run file, it possible your SELinux blocking your application. Get back to Terminal and type this as root:

Cat /selinux/exforce

This will show the current policy of your driver.

To temporarily disable SELinux

Setenforce 0

Hope this can help you.

Login/Register to Answer

Related Questions