CAPI_Worker Module has encountered a problem

Asked By 10 points N/A Posted on -
qa-featured

Hi. When logging on to my Windows XP system, I always got this error message which I don’t understand where it’s coming.

I remember getting the same error when trying to connect my mobile phone to my computer.

I don’t see any major effects on my system, but it is so annoying to see this when my computer started.

How can I get rid of this?

Can you please help?

CAPI_Worker Module

CAPI_Worker Module has been encountered a problem and needs to close. We are sorry for the inconvenience

If you were in the middle of something, the information you were working on might be lost.

Please tell Microsoft about this problem
We have created an error report that you can send to us. We will treat this report as confidential and anonymous.

To see what data this report contains, click here.

SHARE
Best Answer by Bradwell Charles
Answered By 0 points N/A #160592

CAPI_Worker Module has encountered a problem

qa-featured

Hi

This reminded me of the same scenario that I faced when I bought my 1st Sony Ericsson Walkman Series phone. There are two ways of resolving the issue:

You can simply uninstall the Sony Ericsson PC Suite that you may have installed on your system.

Or,

If you have a Bluetooth device connected with your system, you need to uninstall its drivers and get the latest drivers from the bluetooth manufacturer. And reconfigure your PC Suite with the new detected bluetooth device.

As per my understanding, the error message would appear when the system tries to connect to or disconnect from a (default) device. Or when a connected device goes out of range of the bluetooth.

Cheers!

Best Answer
Best Answer
Answered By 0 points N/A #160594

CAPI_Worker Module has encountered a problem

qa-featured

I had the same problem with my Sony-Ericsson PC Suite. After the installation I had this message. Well to fix the problem find the ''Control Panel'' and go to the option ''Add Hardware'', click ''next'' and then it will show you a window that you have to check that you connected your equipment and then ''yes''. After that  you will see a list, find the ''Add new hardware'' click it and then ''next''. Check the ''Install the hardware manually listed'' and ''next''. A list will come off and you will select the ''Ports (COM and LTP)'' and ''next''. You will have two columns. At the first (the Manufacturer column) click the ''Port type standards'' and the second click the ''Communication Port'' and ''next''. ''Finish'', restart your computer and the message won't come off again.

Login/Register to Answer

Related Questions