Can’t use the USB ports on Virtual Box

Asked By 20 points N/A Posted on -
qa-featured

Hello,

I installed Virtual Box on a PC running with Windows 7. Unfortunately, I can't use the USB ports on the machine guest (Windows XP).

In the configuration of the virtual machine, I turned on the EHCI controller for USB 2.0, but when I add a USB device filter (+ button), UBS no device is available, while a USB Drive connected to the PC.

I tried everything I could read in the documentation of Virtual Box, but there must be an installation error somewhere.

I therefore appeal to you to find a solution.

Thank you.

SHARE
Answered By 0 points N/A #79312

Can’t use the USB ports on Virtual Box

qa-featured

OPTION 1:

  1. Open your Virtual Box.
  2. On the Window of your, click Virtual Machine List.
  3. Click the Virtual Machine that you want to be support USB devices.
  4. Click Settings.
  5. Click USB.
  6. Click to select the Enable USB check box.
  7. Click Restart.
  • NOTE: After changing the setting of your Virtual Machine, your Virtual Machine must be restarted.

OPTION 2:

1. Open terminal and run: sudo gedit /etc/init.d/mountdevsubfs.sh

2. You will see a code that looks like this:

  • Magic to make /proc/bus/usb work
  • mkdir -p /dev/bus/usb/.usbfs
  • domount usbfs “” /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
  • ln -s .usbfs/devices /dev/bus/usb/devices
  • mount –rbind /dev/bus/usb /proc/bus/usb

3. Change it to this:

  • Magic to make /proc/bus/usb work
  • mkdir -p /dev/bus/usb/.usbfs
  • domount usbfs “” /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
  • ln -s .usbfs/devices /dev/bus/usb/devices
  • mount –rbind /dev/bus/usb /proc/bus/usb

Login/Register to Answer

Related Questions