Error Cannot open port 80 when trying to run emulator

Asked By 100 points N/A Posted on -
qa-featured

Hi,

I was trying to run a server emulator for some reason. The emulator installed alright but when I try to run it, it says port 80 is already in use. I have tried closing all applications but had no luck so far. Can anyone help please?

SHARE
Best Answer by bug_fix
Best Answer
Best Answer
Answered By 0 points N/A #86839

Error Cannot open port 80 when trying to run emulator

qa-featured

Hey there,

Port 80 is a http port and there could be several programs using it.  If you use LimeWire or any sharing client, check if any of them is running in the background. Kill the processes and try again and see if it works! Have fun!

Answered By 0 points N/A #86840

Error Cannot open port 80 when trying to run emulator

qa-featured

There is another possibility. Do you have a web server running on your PC? The http port is used by servers and other programs cannot access that port, if a server is running. Use a firewall to scan your ports to find out which program is using which port and update us!

Answered By 100 points N/A #86841

Error Cannot open port 80 when trying to run emulator

qa-featured

Yes, I remember I once tried to set up a website on my desktop. I don't actually remember what I did but I didn't download anything. I guess I used the default server application, Windows XP comes with. But I never set up the server successfully. Could that cause any problem with port 80?

Answered By 0 points N/A #86842

Error Cannot open port 80 when trying to run emulator

qa-featured
  1. Open Administrative Tools, and then click Services.
  2. In the Services pane, double-click World Wide Web Publishing Service.
  3. On the Properties page, on the General tab under Service Status, click the Stop button, and then click OK.

Hope this helps!

Answered By 100 points N/A #86843

Error Cannot open port 80 when trying to run emulator

qa-featured

Thanks a lot! Worked for me and now I can install the emulator. Thanks!

Answered By 0 points N/A #86844

Error Cannot open port 80 when trying to run emulator

qa-featured

In your case, the solution posted by arsenal seems more likely! Why did you mark mine as solved. By the way, IIS is not a good way to host a server. The default one, has so many security holes and is not recommended at all. And about the server you are installing, I think you should really install or run a really good firewall, before you emulate the server as it might make your machine vulnerable to attacks. God bless.

Login/Register to Answer

Related Questions