No of visitors who read this post: 1188
Category: MS SQL Server
Type: Question
Author: Ronardeman
No votes yet

 I was installing XAMPP and its services, while suddenly an error popped up about the failed installation of Apache and MySQL saying that ports 80, and 3306 are used.

XAMPP 1.7.4 win32

Ports 80 or 443 (SSL) already in use! Installing Apache2.2 service failed!

OK, I closed all other applications but still the error says that ports 80 and 3306 are already in use.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 30477

This is a very common problem with all the users using Xampp and Apache. To install, you are given two types of options.

One to directly install and launch the application and another is to install. What option you select, depends on your mode. I will recommend you to install and then run the application. For this you will have to install the Apache server, which is running on the port 80 but unfortunately the Microsoft IIS services are also running on this port, which is freely enabled on Windows.
 
That is why Apache is not installing. You have to go to startup and select the IIS service and disable the service. Now install the Apache server and start it.
 
Hope this will solve your problem.
 
Thanks

# Comment Id: 46882

Hi to everyone,

But when it started the xampp console error message appeared:

"Ports 80 or 443 (SSL) already in use! Installing Apache2-2 service failed!"

Then

"Port 3306 already in use! Installing MySQL service failed!"...After stopping all XAMPP components, also un-tick any Svc boxes in XAMPP Control Panel (XCP), double click on (right click and Run as Administrator if Vista) .\xampp\xampp-portcheck.exe and see what is using those ports that XAMPP requires exclusively - all ports should be Free

The 2 main culprits are the Windows Server (IIS - Internet Information Server - disable in the Windows Control Panel) and or Skype (change port in Tools>Options).

Check using Task Manager (right click on the Task Bar and select Task Manager then the Processes tab) for any apache and mysql files running - if so highlight the file and select End process then OK - repeat till all apache and mysql processes have been ended.

Now try again to start the XAMPP components in the XCP - but don't start as a service (don't tick the Svc boxes) unless you want to always have apache and mysql start when you boot your PC.
Thanks in any case.

Janynasima