Cannot configure the external merge tool on Helios Eclipse version

Asked By 0 points N/A Posted on -
qa-featured

Hi,

I tried to install Beyond CVS Plug-in for Eclipse on my Helios Eclipse version. I am have eclipse on my Windows 8, 64bit machine with 4GB or RAM and 200 GB hard disk space. When I try to configure the external merge tool, I get this error. I tried to uninstall eclipse and re-installing again but no joy. I tried restarting the machine and reconfiguring all the parameters but same problem. Anyone have similar problem please help. Will greatly appreciate. Thanks.

An error occurred while trying to compare revisions

Exception: The beyond compare executable could not be found. Please check your preferences and enter into the current location for beyond compare.

SHARE
Answered By 563000 points N/A #178897

Cannot configure the external merge tool on Helios Eclipse version

qa-featured

If you installed Beyond CVS Eclipse plug-in on your Eclipse Helios, you probably configured the external Diff/Merge tool, probably something like this. See image.

And then when you compare, Eclipse hits you with this error. See image.

It turns out that even if you set the correct path in External in the Diff/Merge tool, the error will still say that the Beyond Compare executable is missing and can’t be found in the said location. And this is confusing. The reason for this error is that the external Diff/Merge tool is just a subclipse feature and only applies to opening an external tool for fixing issues after an update or merge.

The Beyond Compare plug-in has a different section in Eclipse to set where the executable is located. To go to the Beyond Compare interface or section, in the search box type without quotes “beyond” then hit Enter. Select Beyond Compare in the result to go to the interface. See image.

Login/Register to Answer

Related Questions