Can’t enable IE9 add on

Asked By 0 points N/A Posted on -
qa-featured

I'm using IE9, but all the add-ons are disabled and I can't enable any of them. They are grayed out. I am using Windows 7 OS if this information helps.

Please help!

SHARE
Best Answer by Bankk benediict
Answered By 0 points N/A #109524

Can’t enable IE9 add on

qa-featured

To enable add-ons on your IE9:

  • Click on Start
  • Type Internet Explorer on Search
  • Click on IE
  • Go to Tools
  • Choose Manage add-ons
  • Click on All add-ons under Show
  • Enable the add-ons you would like to turn on
  • Click on Close

If your add-ons are grayed out and you are unable to manage them, you may:

  • Start IE in normal mode

    • Click Start
    • Choose Run
    • Type iexplore.exe
    • Press Enter
    • Try to manage the add-ons
  • Check the following:

    • Go to Start
    • Type inetcpl.cpl on search
    • Press Enter
    • Go to Advanced tab
    • Check Enable third-party browser extensions
    • Try to manage the add-ons

To manage add-ons further in your IE 9, you may check http://windows.microsoft.com/en-US/windows7/How-to-manage-add-ons-in-Internet-Explorer-9.

Best Answer
Best Answer
Answered By 0 points N/A #109525

Can’t enable IE9 add on

qa-featured

Uninstall and re-install the internet explorer and ensure that the icon you are using to open IE9 is the “normal” icon. You will need to delete the icon and create a new one from the Program Menu; do not select the No Add-on. First, Right click the shortcut icon for IE9 on the desktop, the Click on Properties and select the Shortcut Tab, in case you see – extoff at the end of the path in the Target field, remove it. The IE9 usually has the developer toolbar pre-installed automatically however in some versions of the 32 bits it may be disabled in which case you will need to edit the key from the registry editor.

Answered By 561675 points N/A #277943

Can’t enable IE9 add on

qa-featured

Normally, when you run Windows Internet Explorer in “No Add-ons” mode, you will still be able to access the “Manage Add-ons” option. Other users who encountered this problem have a problem accessing the “Manage Add-ons” option which sometimes is grayed out. There are times the “Manage Add-ons” option is accessible but the option to enable an add-on is grayed out.

Try creating a new user account and then run Windows Internet Explorer from there then check if the add-ons are grayed out. If you don’t see the problem on the new account, your user profile is probably corrupt. Here’s how to fix a corrupt user profile. Launch Windows Explorer then click “Tools” and then “Folder Options”. In “Folder Options”, select “View” tab.

Select “Show hidden files and folders” and uncheck “Hide protected operating system files (Recommended)” then click “OK”. Now, navigate to “C:\Documents and Settings\[corrupt username]” then select all files and folders except for these:

  • NTUSER.DAT
  • ntuser.ini
  • ntuser.dat.LOG

Press CTRL + C to copy. Next, navigate to “C:\Documents and Settings\[new username]” where “[new username]” is the new account you just created. Press CTRL + V to paste the files then select overwrite files when you are prompted. After this, restart your computer and log in using the new account you created. That should fix the problem.

On the other hand, if the problem still happens on the new account, try running Windows Internet Explorer as administrator. One user was able to fix it using this method. Right-click Windows Internet Explorer then select “Run as administrator”. If this works, you need to change the program’s compatibility to always run as administrator. Right-click Windows Internet Explorer then select “Properties”.

Select “Compatibility” tab then under “Privilege Level”, check “Run this program as an administrator” then click “OK”. That should fix it.

Login/Register to Answer

Related Questions