Backup 3 requires Mac OS 10 or later

Asked By 10 points N/A Posted on -
qa-featured

Hi,

Today when I opened Backup this message prompted on my desktop and required for the last updates for my MAC. Now I have checked Software Update from System Preferences and it said that my OS and all the softwares are up to date. What is happening with my MAC ? Anyone had this error and how can it be solved ?

Thank you !

Backup 3 requires Mac OS 10.3.4 or later

To make sure you have the latest update for Mac OS X, choose Apple > Software Update and install the

latest updates for your system.

OK

SHARE
Answered By 564780 points N/A #185092

Backup 3 requires Mac OS 10 or later

qa-featured

If you are having this error on your computer then probably you are using an older operating system not supported by Backup 3. Since the version installed on your computer requires Mac OS X 10.3.4 Panther and higher, check your operating system if this is your current version or maybe higher. If it is then it is good but if not then you need to upgrade your operating system to the required platform or higher.

If you have a much higher operating system than what is required, you may try upgrading your program to version 3.2. You can download it from Backup 3.2 Download. This version requires Mac OS X 10.4.11 Tiger or higher. If you are using a much newer operating system like Mountain Lion or Mavericks, I’m not sure if it’ll still work because it is designed for older operating systems.

Though it says that it requires Mac OS X 10.3.4 Panther or higher, newer operating systems may not support it.

Login/Register to Answer

Related Questions