Authentication that can continue: publickey,keyboard-interactive

Asked By 80 points N/A Posted on -
qa-featured

Hi there,

I use X2go server-client setup for Remote Desktop to my Linux box. I installed X2go Server on my Chrome OS 2.1 and the installation proceeded without any hurdles. However when I try to connect to my Chrome via X2go client I am stuck with this authentication error

 
 
"Authentication failed
 Access denied. Authentication that can continue: publickey, keyboard-interactive"
 
Any help will be handy.
 
Thanks & Regards.
 
Hunter
SHARE
Best Answer by Agail etthan
Answered By 0 points N/A #149761

Authentication that can continue: publickey,keyboard-interactive

qa-featured

Hello Hunter,

You will need to make sure that your AuthorizedKeysFile line is  reading AuthorizedKeysFile .ssh/authorized_keys. Also, you will need to ensure that the permissions on your .ssh directory are 700 and the permissions on your authorized_keys file is 600.

Regards,

Nicke

 
Best Answer
Best Answer
Answered By 0 points N/A #149762

Authentication that can continue: publickey,keyboard-interactive

qa-featured

Hello,

To fix this problem, you need to open Terminal and edit the file /etc/ssh/sshd_config.

Then find the following lines and modify to match: Challenge Response Passwords must be changed to “yes” to enable and then on the Challenge Response Authentication it must be “no”.

Change also to “no” to disable tunneled clear text passwords and choose “yes” for Password Authentication. Lastly, restart sshd.

Then, try to connect to the Chrome OS X2go server using X2go client.

It should be working well.

 

Login/Register to Answer

Related Questions