Apache on my computer using Belkin wireless router

Asked By 0 points N/A Posted on -
qa-featured

I have set up Apache on my computer using Belkin wireless router that is linked to the cable modem of my internet service provider. Well, the problem is that I am not able to reach Apache from the internet or any other location for that matter but I can reach it on local host and 127.0.0.1 .I redirected port 80 to the right computer using my Belkin router which contains hypertext transfer protocol daemon  settings so that it can work on 8080.

This is in case if 80 have been barred. I inactivated windows firewall and Belkin firewall .However I couldn’t open the webpage from a network from outside. I therefore switched off firewall and so I am just wondering whether I made a mistake in the settings of hypertext transfer protocol or in the settings of windows security.

SHARE
Best Answer by techrob
Best Answer
Best Answer
Answered By 0 points N/A #111575

Apache on my computer using Belkin wireless router

qa-featured

David,

So to make sure I'm understanding you correctly. You want to be able to access your web server from outside possibly using a network address or host name. It seems you are able to reach the web server from within your network but outside you have issues. I'm not too sure on the features of a Belkin wireless router. I mainly have used and worked with Link sys and Cisco but I'm sure they all have some similarities with features.

So what I have done in the past to access a web server externally is I have placed the IP address of my web server and port within the DMZ settings of my wireless router. This allows for me to still keep my server secure but make that port and server available so I can access via the web. Now because I have an ISP it has usually be one with a natt'ed ip address unless I was using a free services to provide me with DNS.

Another note to point out being that you are also using a firewall within your network, you will need to make sure no conflicts are being caused. So check your logs to see if this might be happening. So my recommendation to solve this issue would be to look at your router settings and see if you are able to publish the web server ip address and port through that method. Good luck and hope this helps!

Thanks

Answered By 0 points N/A #111576

Apache on my computer using Belkin wireless router

qa-featured

Hi David,

I suggest you to read about parallel computing latest updates on the link below. That will help you solve your problem.

http://www.drdobbs.com/go-parallel

You can also open your browser and then enter http://localhost:8080 or http://ip:8080

You can solve your problems by doing any of the solution I gave you. Those are proven and tested. Let me know if any of them will work. Thanks in advance and have a good day.

 

-Zorian

Login/Register to Answer

Related Questions