Apache could not be started after replacing PHP 5.3.5 to PHP 5.3.8

Asked By 0 points N/A Posted on -
qa-featured

 

I’m new to XAMPP and I’d like to learn about it, some trial and error I guess. After I installed XAMPP version 1.7.4 which is using PHP 5.3.5, I need to upgrade the PHP version to the latest.

I downloaded newest PHP version (5.3.8) and then I replace the folder “C:xamppphp” with my new PHP version. But guess what, everything is not running well. I manage to shutdown my Apache service. But I could not start it again. I’ve tried start the apache service using XAMPP Control Panel and Services under Computer Management. Please take a look at the picture below.

It give some message like this “Windows could not start the Apache2.2 on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1.”

SHARE
Best Answer by Anderson Wright
Best Answer
Best Answer
Answered By 0 points N/A #120207

Apache could not be started after replacing PHP 5.3.5 to PHP 5.3.8

qa-featured

Hi Michael,

    Possible scenario is that your Apache and Teamviewer are open on 80, means the same tcp ip port. The Xampp virtual machine was being interrupted by the Teamviewer.  A change in load or tcp ip port is necessary. Here are the possible quick fixes regarding your queries.

  •  Open your Teamviewer by typing at Windows service startup.
  • Then proceed to settings of Teamviewer. Set it to do not start up option .
  • Restart your System.
  • Open your xampp control panel. Enable all the services available same as windows service.
  • Then again, restart your system.


Hope this quick fix could help in your queries.

Best Regards,
A.Wright.

Answered By 0 points N/A #196678

Apache could not be started after replacing PHP 5.3.5 to PHP 5.3.8

qa-featured

Hi,

 I feel this is a deadlock situation and you must end deadlock for insuring Apache to run smoothly. It might be that two processes are trying to run at the same time and that is creating all kind of problems. You need to take yourself out of that problem or this problem will persist. Shut down the computer and restart. If problem persist then check, which processes are running simultaneously. Are they creating deadlock and if yes then close any one and start Apache. Finally restart that process again.

Waters Magner

Login/Register to Answer

Related Questions