Age of Empire 3 error

Asked By 10 points N/A Posted on -
qa-featured

Hello everyone,

I had installed Age of empire 3 trial version and when I tried to play I got the error below. I have tried the steps in the error message to troubleshoot but no luck yet. In the log file I do not understand the information but I guess it is just more to what is given on the error. I had done the installation on Windows 7.

Error message:

Initialization Failed

Direct3D initialization failed. Possible causes:

Old or corrupted graphics driver.

Direct3D improperly installed.

Hardware acceleration disabled.

Starting the application with the workstation locked.

Please check the log file for more information

SHARE
Answered By 0 points N/A #183074

Age of Empire 3 error

qa-featured

Hi,

The problem might be you don’t have the patch to play the game on Windows 7. Try first the following:

1.   Open the game directory.

2.   Right click age3.exe file and open properties.

3.   Click on compatibility tab.

4.   In compatibility mode tick on “run this program in compatibility for…  Windows XP

5.   In privilege level tick on “run this program as an administrator”

6.   OK

Launch the game.

If this doesn’t solve the problem try downloading the latest patch for Age of Empires 3. In the following link you can find the patch.

http://www.ensemblestudios.com/gameUpdates.aspx

Login/Register to Answer

Related Questions