Adobe Photoshop Lightroom V 3 5 crashes on Lion

Asked By 50 points N/A Posted on -
qa-featured

Hello.  I have been using Adobe Photoshop Lightroom v 3 5 for managing my image application database.  I have now upgraded to OSx Mountain Lion.  I cannot use Lightroom anymore as it always crashes.  What could be the problem?  Thanks in advance.

SHARE
Best Answer by Sharath Reddy
Best Answer
Best Answer
Answered By 564965 points N/A #145032

Adobe Photoshop Lightroom V 3 5 crashes on Lion

qa-featured

It seems that the thing you want to happen will really not happen because Adobe Lightroom 3.5 is no longer compatible with your present operating system, Mac OS X 10.8 Mountain Lion. If you have been successfully using it for the past time maybe it’s because you are still running your computer with a supported operating system like Mac OS X 10.7 Lion maybe.

Adobe Lightroom 3.5 doesn’t support Mac OS X 10.8 Mountain Lion and will only work on Mac OS X 10.5 Leopard until Mac OS X 10.7 Lion. There is really no solution to this unless you decide on downgrading your present platform to Mac OS X 10.7 Lion which is somewhat not a good idea because you are already using a newer edition of Mac OS X.

Because you are already running Mac OS X 10.8 Mountain Lion, your best option is to use a more suitable version such as Adobe Lightroom 5 which supports Mac OS X 10.7 Lion, 10.8 Mountain Lion, and the latest Mac OS X 10.9 Mavericks. The next version after Adobe Lightroom 3.5 is Adobe Lightroom 4 and it also doesn’t support your operating system because they have the same supported platforms.

For more information about Adobe Lightroom 5 and in case you decide on buying it, please visit Adobe Photoshop Lightroom 5. The upgrade costs around $79.

Login/Register to Answer

Related Questions